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Outline of the Course

Introduction to web programming and ASP.NET

Create web application using Visual Studio® 2010 and C#
Create and add code-behind file to an ASP.NET web form
Examine common ASP.NET Controls

Connecting to a Database in an ASP.NET application and ASP.NET Data
Controls

Session management

Validation controls

Master pages

Configuring and deploying an ASP.NET web application on an IIS server
Securing an ASP.NET web application

Introduction to ASP.NET AJAX

Introduction to WCF (Windows Communication Foundation)
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Web Technologies

* HTTP / HTTPS (URL, GET/POST)

* Client-side:
— HTML / XHTML (Extensible HyperText Markup Language)
— JavaScript / VBScript (client-side scripting)
— Applets / ActiveX controls

* Server-side:
— PHP
— Phython
— JSP (Java Server Pages)
— ASP (Active Server Pages)
— ASP.NET (next generation of ASP)
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Server-Side Code
e \Whatis server-side code?

— Software that runs on HTTP request A
the server, not the (form data, HTTP response
client HTTP HTML, XML
. . header data
— Receives input from )v

* URL parameters
e HTML form data

— Can access server-side ASP- Page
datab | (static HTML,
atabases, e-mal server-side
servers, files, logic)

mainframes, etc.

— Dynamically builds a
custom HTML
response
for a client
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ASP.NET Overview and Features

® ASP.NET provides services to allow the creation, deployment, and
execution of
Web Applications and Web Services

® Web Applications are built using Web Forms

® \Web Forms are designed to make building
web-based applications as easy as building Visual Basic applications

® Built on .NET Framework: any .NET programming language can be used
(C#, Visual Basic)

® Complete object model

® Separation of code and Ul

® Maintains page state

® Session management

® Caching, Debugging, Extensibility
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WebTime.aspx Example
Creating an ASP.NET Web Application using Visual Studio

Step 1: Creating the Web Application Project

» Select File > New Web Site... and choose ASP.NET Empty Web Site in the
Templates pane.

* Select File System from the drop-down list closest to Location.

* Set the Language to Visual C#, and click OK.

Mew Web Site

Recent Templates \MET Eramewor ||| Sort by: |Default
Installed Templates
Type: Visual C#
i N ;’# ASP.MET Web Site Visual C# v
i II I Iii H=C An empty Web site
m Gﬁ ASP.MET Empty Web Site Visual C#
Online Templates

Cﬁ %" ASP.MET Dynamic Data Entities Web Site Visual C=
ASP.MET Dynamic Data Ling to SQL Web Site Visual C#=

WCF Service visual C=

ASP.MET Reports Web Site Visual C#

$ U %Y

ASP.MET Crystal Reports Web Site Visual C#

Web location: File System IEI d: Yy Documen t=iWisual Studio 2010WebSites\WiebSite 3 |E|
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wWebTime.aspx Example

Add n ASPX file (i.e., Web Form), default named Default.aspx
is created for each new project.

Visual Web Developer creates a code-behind file named
Default.aspx.cs.

The view Designer button opens the Web Form in pesign mode.

The copy Web site button allows you to copy the project’s files to
another location, such as a remote web server.

Finally, the Asp.NET Configuration button takes you

to the web Site Administration Tool.

Look at Toolbox displayed in the IDE when the project loads.
— Standard and Data list of web controls.
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Editing the WebT1me.aspx

When the project loads for the first time, the Web Forms Designer displays
the autogenerated ASPX file in Source mode.

Design mode indicates the XHTML element where the cursor is currently
located.

You can also view both the markup and the web-page design at the same
time by using Split mode

Right click the ASPX file in the Solution Explorer
and select View Code to open the code-behind file.
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webTime.aspx Example

e Let’s create our first ASP.NET page using Visual Studio
Modify title of the page

Add a heading <h2>

Look at the page in Design and Split modes

Add a Label control from the Toolbox

Change ID of the Label control

Change some physical properties of the Label control

Go to webTime.aspx.cs file and add Page_Init
function to set TeXt property of the Label control

N o U AW E
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WebTime.aspx Example

Changing the Title of the Page

We change the page’s title from the default Untitled Page to A Simple Web Form
Example.

Open the ASPX file in Source mode and modify the text between the <title> tags.

Alternatively, you can modify the Web Form’s Title property in the Properties
window.

To view the Web Form’s properties, select DOCUMENT from the drop-down list in
the Properties window.

Designing the Page

To add controls to the page, you can drag and drop them from the Toolbox onto the
Web Form in Design mode.

Like the Web Form itself, each control is an object that has properties, methods and
events.

You can type text directly on a Web Form at the cursor location or insert XHTML
elements using menu commands.
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Renaming the WebT1me.aspXx

Renaming the ASPX File

® Right click the ASPX file in the Solution Explorer and select Rename.

® Enter the new file name WebTime.aspx and press Enter. Both the ASPX file
and the code-behind file are updated.

Renaming the Class in the Code-Behind File and
Updating the ASPX File

® \isual Studio’s refactoring tool, which automatically updates the
existing references to this class in the rest of the projectto  reflect this
change.

® Right click the class name in the partial class’s declaration and select
Refactor > Rename... to open the Rename dialog.
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Visual Studio generates the markup shown when you create the GUI.

1 <%-- WebTime.aspx --%>

2 <%-- A page that displays the current time in a Label. --%>
anguage="C#" AutoEventwireup="true"

3 <%@, Pa
Co eF1f g'eWe Time.aspx.cs

4 Inherits="webTime" EnableSessionState="False" %

5
6 <IDOCTYPE html PUBLIC "-//W3C//DTD XHTML

1.0 Transitional//
7 "http://www.w3.org/TR/xhtm11/DTD/xhtm11- nsitiEEET>dtg

8

9 <html xmlns="http://www.w3.0rg/1999/xhtml1">

10 <head runat="server'>

11 <title>A Simple web Form Example</title>

ASP.NET comments begin
with <%-- and terminate with
--%>, and can span multiple
lines.

\

The Page directive specifies
information needed by
ASP.NET to process this file.

12 </head>
13 <body>
14  <form id="forml" runat="server">
15  <div>

<
<«

16 <h2>Current time on the web server:

The form that contains our XHTML text and
controls is set to execute on the server, which

generates equivalent XHTML.

The document type declaration, which
specifies the document element name
and the PUBLIC URI for the DTD that
defines the XHTML vocabulary.

</h2>

The body contains the main
content that the browser
displays.

ASPX file that displays the web server’s time.

XHTML documents have the
root element htm1 and
markup information about the
document in the head
element.

14
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WebTime.aspx

17 <p> (20f2)
18 <asp:Label ID="timeLabel" runat="server" BackColor="Black"—
19 Font-Size={XX-Large" ForeColor="yellow" B
20 Enableviewstate="False"></asp:Label>
21 </p> The asp 1 - Markup for a label
) e . tag prefix
22 </div> indicates that the YAEID COMIEL.
23 </form> label is an ASP.NET
web control, not an
24 </body> XHTML element.
25 </html>

* In an ASPX file a directive is delimited by <% @ and %>.

ASPX file that displays the web server’s time. (Part 2 of 2.)
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wWebTime.aspx Example

The Page directive’s Language attribute specifies the
code-behind file’s language.

The CodeFile attribute specifies the code-behind filename.

When AutoEventWireup is true, ASP.NET automatically treats a method of
name Page eventName as an event handler.

When AutoEventWireup is set to false, you specify event handlers using
attributes in the Page directive just as you would any other web control.

The Inherits attribute (line 4) specifies the class in the code-behind file
from which this ASP.NET class inherits.
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wWebTime.aspx Example

The document type declaration, which specifies the document element
name and the PUBLIC URI for the DTD that defines the XHTML vocabulary.

XHTML documents have the root element html and markup information
about the document in the head element.

Setting the runat attribute to "server” indicates that ASP.NET processes
the element and its nested elements and generates the corresponding
XHTML.

The body contains the main content that the browser displays.

The form that contains our XHTML text and controls is set to execute on
the server, which generates equivalent XHTML.
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wWebTime.aspx Example

 The ID attribute assigns a name to a control, used as
an identifier in the code-behind file.

* The asp: tag prefix indicates that the label is an
ASP.NET web control, not an XHTML element.

* Each web control maps to a corresponding XHTML
element or group of elements.
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webTime.aspx Example

The asp:Label control is written as an XHTML span
element.

A span element contains text with formatting styles.

This control is processed on the server so that the
server can translate the control into XHTML.

If this is not supported, the asp:Label element is
written as text to the client.
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The code-behind file (webT1me.aspx.cs)

1 // WebTime.aspx.cs

2 // Code-behind file for a page that displays the current time.
3 using System;

4

5 public partial class webTime : System.web.UI.Page

6 { p

7 // initializes the contents of the page

8 protected void Page_Init( object sender, EventArgs e )

9 {

10 // display the server's current tiffe in timeLabel

11 timeLabel.Text = DateTime.Now.ToString( "hh:mm:ss™ );

12 } // end method Page_Init
13 } // end class webTime

Code-behind file for a page that displays
the web server’s time. (Part 1 of 2.)

The Page_Init
method handles the
page’s Init event,
which indicates that
the page is ready to
be initialized.

Retrieve the current
time and formats it
as hh:mm:ss.
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webTime.aspX Example Run

& A Simple Web Form Example - Windows Inteme...@lgu

O@ « | &) httpi//locathost:so v | 44 | x || Google
"i:l? Eﬁ [ﬁhﬁimpleWeh Form Exa... l_l ﬁ -

o

Current time on the web server:

03:11:49

-

& Internet | Protected Mode: On H100% ~ r

* The Page Init method handles the page’s Init event,
which indicates that the page is ready to be initialized.
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wWebTi1me.aspX Example

Relationship Between an ASPX File and a
Code Behind File

The code-behind file inherits from Page, which defines the
general functionality of a web page.

The code-behind file contains a partial class.

ASP.NET generates another partial class that defines the
remainder of that class, based on the markup in the ASPX file.

The first time the web page is requested, this class is
compiled, and an instance is created.

This instance represents our page—it creates the XHTML that
is sent to the client.

Once an instance of the web page has been created, multiple
clients can use it to access the page—no recompilation is
necessary.
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wWebTime.aspx Example
How the Code in an ASP.NET Web Page Executes

® \When an instance of the page is created, the Prelnit event occurs first,
invoking method Page Prelnit, which can be used to set a page’s theme.

®The Init event occurs next, invoking method Page Init, which is used to
initialize objects and other aspects of the page.
® Next, the Load event occurs, and the Page Load event handler executes.
e The Init eventis raised only once (when the page is first requested).
® The Load event is raised with every request.

® The page then processes any events that are generated by the page’s
controls.

® Once a response has been generated and sent, an Unload event occurs,
which calls Page_Unload, which typically releases resources used by the

page.
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wWebTime.aspXx Example

* To view the XHTML generated by ASP.NET, select View Source

from the Page menul|:;page » in Internet Explorer (or View >
Page Source if you are using Firefox).

* Nonvisual form components, called hidden inputs, store data
that the user doesn’t need to see.

» Attribute method of the form element specifies the request
method (usually get or post). The action attribute identifies
the resource that will be requested when a form is submitted.
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 Figure shows the XHTML generated by ASP.NET when a web
browser requests webTime. aspx.

<!-- webTime.html -->

<!-- The XHTML generated when webTime.aspx is loaded. -->

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.0rg/TR/xhtml111/DTD/xhtm111.dtd">

<html xmins="http://www.w3.0rg/1999/xhtm1">
<head>

<title>A Simple web Form Example</title>

© 00 N O O b W N P

A

</head>

<body>

11 <form method="post" action="webTime.aspx" id="forml">
12 <div>

[EEN
o

13 <input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value=
14 "/WEPDWUJODEXMDE5NZY52GQ4n4mht8D7qun73tM5LDnstP]Cg==" />
15 </div>

Fig. | XHTML response when the browser requests

wWebTime.aspX. (Part 1 of 2.)

Attribute method
of the form
element specifies
the request method
(usually get or
post). The
action attribute
identifies the
resource that will
be requested when
a form is
submitted.

Nonvisual form
components,
called hidden
Inputs, store data
that the user
doesn’t need to
see.




26
27
28

<div>
<h2>Current time on the web server:</h2>
<p>
<span id="timeLabel" style="color:Yellow;
background-color:Black;font-size:Xx-Large;">
03:11:49
</span>
</p>
</div>
</form>
</body>
</html>

Fig. | XHTML response when the browser requests
wWebTime.aspX. (Part 2 of 2.)

The form contains a
span element to
represent the text in
the label. Formatting
properties of
timeLabel are
converted into the
sty e attribute of
the span element.
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wWebTime.aspXx Example

* When the form is processed on the server, the
runat attribute is removed.

* Only those elements marked in the ASPX file
with runat="server" are modified or
replaced in the generated XHTML.
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wWebTi1me.aspXx Example

The positions of controls and other elements are relative to
the Web Form’s upper-left corner. This type of layout is
known as relative positioning.

An alternate type of layout is known as absolute positioning,
in which controls are located exactly where they are dropped
on the Web Form.

You can enable absolute positioning in Design mode in the
HTML Designer > CSS Styling node of the Options dialog.

Absolute positioning is discouraged, because pages designed
in this manner may not render correctly in different
browsers or on computers with different screen resolutions
and font sizes.
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Running WebT1me.aspXx Example

Running the Program

* You can view the Web Form several ways.

— You can select Debug > Start Without Debugging, which runs the
application by opening it in a browser window.

— To debug your application, you can select Debug > Start Debugging.
You cannot debug a web application unless debugging is explicitly
enabled by the web.config file.

— To view a specific ASPX file, you can right click either the Web Forms
Designer or the ASPX file name and select View In Browser.

— Finally, you can run your application by opening a browser window
and typing the web page’s URL in the Address field.
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Event Handling

e GUIs are event driven.

 When the user interacts with a GUI
component, the event drives the program to
perform a task.

* A method that performs a task in response to
an event is called an event handler.
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Event Handling Example (He11owor1d)

e Let’s create another ASP.NET page using Visual Studio

Add a Button anda Label control

To create this click event handler, double click the Button on the Form.
The following empty event handler is declared:

Set the Text property of the Label control with the current time in
this function.

ol S

protected void Buttonl_Click(object sender,
EventArgs e)

{
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Event Handling Example (He11owor1d)

 To add an event handler, alternatively in markup

(aspx) file:
1. Addaonclick="BClick" property tothe Button
control.

2. Add a function BC11ck to the page class in the code
behind.
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H e I | OWO r I d E Xa I I I p | e I ASP.NET comments begin with <%-- and terminate with --%6>, and can span multiple lines. |

The Page directive specifies information
needed by ASP.NET to process this file.

<%-- Hello World page that also displays the current time. --%>

%@ Page Language="C#" AutoEventWireup="true"
CodeFile="HelloWorld.aspx.cs" Inherits="HelloWorldPage" %>

<!'DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.0rg/TR/xhtmll/DTD/xhtmll-transitional.dtd">

XHTML documents have the root element htm1 and markup I

<html xmlns="http . //WWW . W3 . org/l 999/xhtml "> information about the document in the head element.
<head runat="server'">
<title>Hello World Web Form</title>

</head>
The body contains the main content that the browser displays. The form that contains our XHTML text and controls is set to execute on the server,
<b0dy> which generates equivalent XHTML.

<form id="forml" runat="server'">

<asp:Button ID="buttonClick" runat="server" Font-Size="Medium"
Width="102px"“ Text="Click Me" onclick="BClick" />

<br />

<asp:Label ID="labelHello" runat="server'"></asp:Label>

</form>
</body> </html>

The asp: tag prefix indicates that the label is an ASP.NET web control, not an XHTML
element.

Markup for label & button web controls.




S. S Jain Subodh P.G. (Autonomous) College

ASPX Code Behind File

public partial class HelloWorldPage
System.Web.UI.Page

protected void BClick (object sender, EventArgs e)

{
labelHello.Text = "Hello World! Time is " +

DateTime.Now;
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Event Handling

* By convention, C# names the event-handler method
as objectName_eventName (€.g., Buttonl_c1ick).

* Each event handler receives two parameters when it
IS

called:

— An object reference named sender—a reference to the
object that generated the event.

— A reference to an object of type EventArgs, which
contains additional information about the event.
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Other Ways to Create Event Handlers

* Typically, controls can generate many different types of
events.

e Clicking the Events icon (the lightning-bolt icon) in the

Properties window, displays all the events for the selected
control. Properties

Buttonl System.Web, I WebCor| -

== M = # |
Bz |2d || E |4 I

Click, Buttonl_Click
Cormard

DrakaBinding

Dizsposed

Init

Load

PreRender

Unload

Click
Fires when the butkon is clicked.
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Locating Event Information

* Tolearn about the events raised by a control, select Help > Index.

* |nthe window, select Web Development (.NET) in the Filtered by drop-
down list and enter the name of the control’s class in the Index window.

(2 Hutton Weh' Server Control Declarative Syntax - Microsoft Yisual studio 2008 Doco

File  Edit “iew  Tools  Window  Help

[#] & A” @ HowDol - O Search |3 Index &3 Contents [ T|Help Favorites
Button Web Ser...arative Syntax  se=5rch |

dex
1 : URL: ms-help: /iMS, wSCC, w30 MS, MSDMNO TR, w30, er
| Web Development {.MET) \@
¥ Code: all

= = Collapse all
| Look For: MET Framework General Reference

: Button Web Server Control De

al
"""""""""""" [:] Example See Alsc Send Feedback

determining coordinates .
Dizplays a push button control on the Web

events
Butkon control [wWindows Farms]
(See alzo Bukkon class) <asp:Button
B Button parameter LrooessKewv="string™
butkonActivate = E kCol T i :ﬁg dddde
ButbonClick ackColor="color name | 4
buttonHeight Borderlolor="color name|#ddd 37

RrnrdsasrSt+ao]l e="MMntSat | Tnne= | Tint

T TR T T
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Programming Model
Controls and Events

List T
.

—/U

e

Label

Browser ASP.NET Event handlers
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ASP.NET Architecture

ASP.NET: Web Services Windows
and Web Forms Forms

<
(7))
c
L
%
c
=
e
p
M
—

ADO.NET: Data and XML

Base Classes
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Programming Model
ASP.NET Object Model

Controls are objects, available in
server-side code

— Derived from System.Web.UI.Control
The web page is an object too
— Derived from System.Web.UI.Page

User code executes on the web server in
page or control event handlers
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